New look, same old content…

Published May 15th, 2008

I’ve been running this blog-based iteration of my site for almost three years now, and recently — after numerous on-the-fly software updates — I’ve found that WordPress had become rather unstable and slow. So yesterday I decided that I’d had enough and it was time to start again with a clean slate.

The basic process was relatively painless: I created a temporary subdomain and installed a fresh copy of WordPress, then used its built-in export/import facilities to transfer all the existing articles and comments over. Then I had to install all the various plugins I’d accumulated over the years (Akismet, Bad Behavior, Code Markup, Google XML Sitemaps, OpenID Registration) and configure them appropriately. I couldn’t find an up-to-date version of the old theme I was using, so I spent a while browsing before finding this one, which I’m fairly happy with although I might tweak here and there as time goes on.

Finally I had to do some work to re-integrate the various ad spots and a few other bits and bobs (e.g. point the RSS links to FeedBurner) before the installation was complete. All in all, it was probably half a day’s work, which I think is acceptable for a complete restart.

So I hope you like the new look. If you spot any problems then please let me know via the comments form below.

Get a Trackback link

No Comments Yet

Be the first to comment!

Leave a comment

Comment Policy: First time comments are moderated. Please be patient.

OpenID

Anonymous